/* СТИЛИ СТИЛИ СТИЛИ СТИЛИ СТИЛИ СТИЛИ СТИЛИ СТИЛИ СТИЛИ ССТИЛИ */

[#DCBEELINEKZ] БИЛАЙН ХАБЫ КАЗАХСТАН

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » [#DCBEELINEKZ] БИЛАЙН ХАБЫ КАЗАХСТАН » [OPENWRT/LEDE ] » Настройка L2TP-соединения ("Интернет Дома" Билайн Казахстан) в OpenWRT


Настройка L2TP-соединения ("Интернет Дома" Билайн Казахстан) в OpenWRT

Сообщений 1 страница 4 из 4

1

Как подключить L2TP для BEELINE KZ "Интернет Дома" на примере  роутера TP-Link TL-WR740N под управлением прошивки LEDE/OPENWRT.

В стандартной сборке LEDE/OpenWRT отсутствуют модули для установления L2TP-соединения xl2tpd. Так как роутер пока не имеет выхода в интернет, загрузить установочные пакеты (с зависимостями) придется вручную, используя WinSCP.

Либо прошиться моей сборкой с вырезными не нужными пакетами с нее (IPv6, debug) и добавленными пакетами (xl2tpd, русский язык, разлочена возможность перезаписи U-BOOT).
Там так же другие мои прошивки с возможными вариантами подключения к нэту (pppoe, pptp и полностью без PPP), тока для модели роутера 740n 4 версии.

Готовые прошивки: На форуме 4PDA


Для тех кто устанавливает xl2tpd.

Открыть

Сам пакет xl2tpd и зависимости к нему для его работы: ip, resolveip, kmod-l2tp, kmod-pppol2tp, ppp-mod-pppol2tp. Скачиваем все вышеперечисленное в отдельную папку на ПК (должно получится 6 файлов с расширением *.ipk) и переименовываем файлы для удобства последующей установки, оставляя только название пакета и расширение (к примеру, «resolveip_2_ar71xx.ipk» стоит переименовать в «resolveip.ipk»), хотя это не обязательно.

Для ar71xx (mips_24kc) LEDE 17.01.4 пакеты тут:


1. Запускаем WinSCP и подключаемся к роутеру по протоколу SCP, используя сетевой адрес роутера (по умолчанию — 192.168.1.1), имя пользователя — root и назначенный вами пароль. Переходим в каталог /tmp и копируем туда наши 6 файлов.

2. Запускаем SSH-клиент Putty для доступа к CLI роутера. Протокол — SSH, порт 22, данные для соединения те же, что и для WinSCP. После установления соединения вы сразу оказываетесь в домашнем каталоге /root.

Переходим в папку /tmp.

cd /tmp


Удостоверьтесь, что нужные для установки файлы присутствуют в каталоге, для этого наберите:

ls


ip
resolveip
kmod-l2tp
kmod-pppol2tp
ppp-mod-pppol2tp
xl2tpd_devel

Для установки используйте команду:

opkg install ip.ipk
Повторите процедуру установки для каждого пакета в указанной очередности. На каждом этапе должно быть сообщение об успешной установке.

Подключение к VPN Билайну

Переходим в веб-интерфейс LuCi роутера 192.168.1.1, закладка Network (Сеть). У вас там должны быть два интерфейса — wan и lan.

https://pp.userapi.com/c840337/v840337786/6db88/oQinOeN_eoY.jpg

Создайте новый интерфейс (Network — Add new interface…), назовите его например BEELINEKZ, в качестве типа протокола укажите L2TP, нажмите Submit.

https://pp.userapi.com/c840337/v840337786/6db91/s4ntiPlQWSE.jpg

Откроется окно настроек нового интерфейса. Укажите имя сервера (l2tp.internet.beeline.kz), а также ваши логин и пароль.

https://pp.userapi.com/c840337/v840337786/6db9a/Hp_9z_1kqZk.jpg

Перейдите на вкладку Firewall (Настройки межсетевого экрана) и добавьте интерфейс BEELINEKZ в зону wan, сохраните изменения.

https://pp.userapi.com/c840337/v840337786/6dbec/obx1oQU0M9w.jpg

После всех манипуляций перезагружаем роутер.

В PuTTY это:

reboot


После перезагрузки, Зайдите на роутер через веб-интерфейс, проверьте вкладку Network (Интерфейсы).
На всех трех интерфейсах (lan, wan, BEELINEKZ) должны быть назначены IPv4-адреса.
И все настройка L2TP-соединения  закончена!

https://pp.userapi.com/c840337/v840337786/6dbf5/Nl4h5p2lvXc.jpg

Тут две темы, которые помогут в других вариантах, но все равно одно и тоже.
Если голова шарит, то не должно быть в этой настройке большой проблемы!

Еще одна тема

https://sae762.files.wordpress.com/2015/12/openwrt2-ifs.jpg?w=503&h=358

Подключил я значит интернет от Билайна. Мне пришли техники и поставили роутер TL-WR740N Ver.:6.0. Сидел и думал, а не прошить ли мне его. Подумал и решился, пошел гуглить. Хотел сначала поставить dd-wrt, но для данной версии на официальном сайте не оказалось, только до версии Ver.:4.x. Стал искать дальше и нашел прошивку от OpenWRT для Ver.:6.0. Скачал прошивку для этой модели и версии. Прошивка squashfs-factory.

После обновления я столкнулся с проблемой, у меня не поставился WEB интерфейс. Как оказывается в самом роутере настолько урезали память, что ее не хватает на установку WEB интерфейса. Еще выяснилось, что в стандартной сборке отсутствуют модули для установления L2TP-соединения. Поэтому настоятельно рекомендую загрузить установочные пакеты (с зависимостями) заранее вручную. Скачиваем все ниже перечисленное в отдельную папку на ПК.

ip-full_4.4.0-2_ar71xx.ipk
resolveip_2_ar71xx.ipk
kmod-l2tp_4.4.14-1_ar71xx.ipk
kmod-pppol2tp_4.4.14-1_ar71xx.ipk
ppp-mod-pppol2tp_2.4.7-9_ar71xx.ipk
kmod-udptunnel4_4.4.14-1_ar71xx.ipk
kmod-udptunnel6_4.4.14-1_ar71xx.ipk
xl2tpd_devel-20151125-3_ar71xx.ipk

С помощью программы WinSCP заходим на роутер. Протокол передачи выбираем "SCP", логин: root, пароль: без пароля. Далее поднимаемся на уровень выше по каталогу и переходим в паку /tmp и туда копируем выше скачанные файлы.
Затем запускаем программу Putty, подключаемся через нее к нашему роутеру. Переходим в папку /tmp.

Код:
cd /tmp


Устанавливаем пакеты по порядку.

Код:
opkg install ip-full_4.4.0-2_ar71xx.ipk
opkg install resolveip_2_ar71xx.ipk
opkg install kmod-l2tp_4.4.14-1_ar71xx.ipk
opkg install kmod-pppol2tp_4.4.14-1_ar71xx.ipk
opkg install kmod-udptunnel4_4.4.14-1_ar71xx.ipk
opkg install kmod-udptunnel6_4.4.14-1_ar71xx.ipk
opkg install ppp-mod-pppol2tp_2.4.7-9_ar71xx.ipk
opkg install xl2tpd_devel-20151125-3_ar71xx.ipk



Кто с 4PDA с моей ссылки выше ставить ниче не нужно, все уже стоит в моей прошивке с этой темы по ссылке!

Открываем файл network текстовым редактором vi. Заранее посмотрите в интернете как пользоваться текстовым редактором vi.
Но я предпочитаю использовать программу WinScp, ею проще редактировать и производить любые действия с файлами внутри роутера.

Код:
vi /etc/config/network


Добавляем в config interface 'wan' параметр: option reqopts 'routes msstaticroutes'. Вот как будет выглядеть.

Код:
config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option reqopts 'routes msstaticroutes'


Ниже добавляем новый конфиг для нашего Билайн и сохраняем. Здесь указываем ваш логин и пароль от Билайна. Все это сохраняем.

Код:
config interface 'beelinekz'
        option proto 'l2tp'
        option server 'l2tp.internet.beeline.kz'
        option username 'логин'
        option password 'пароль'
        option keepalive '20 5'
        option defaultroute '1'


Перезагружаем службу network.

Код:
/etc/init.d/network restart


Теперь нужно проверить поднялось ли наше соединение.

Код:
ifconfig


Должно в списке появиться l2tp-beelinekz, если не появилось, то проверьте все ли ввели верно.

l2tp-beelinekz Link encap:Point-to-Point Protocol 
          inet addr:5.34.20.32  P-t-P:77.74.65.242  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1460  Metric:1
          RX packets:438372 errors:0 dropped:0 overruns:0 frame:0
          TX packets:391889 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:291880224 (278.3 MiB)  TX bytes:194568451 (185.5 MiB)

Теперь нужно заставить, чтобы интернет раздавался на устройства в локальной сети, для этого открываем firewall.

Код:
vi /etc/config/firewall


Правим config zone wan, приводим в такой вид и сохраняем.

Код:
config zone                                            
        option name             wan                    
        list   network          'beelinekz'            
        list   network          'wan6'                 
        option input            REJECT                 
        option output           ACCEPT                 
        option forward          REJECT                 
        option masq             1                      
        option mtu_fix          1


Перезагружаем наш firewall.

Код:
/etc/init.d/firewall restart


После этого можно проверить интернет на компе. Далее настраиваем wi-fi.

Код:
vi /etc/config/wireless


Приводим его в такой вид и сохраняем.

Код:
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option hwmode   11g
        option path     'platform/qca953x_wmac'
        option htmode   HT20
        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 0

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     Wi-Fi #здесь указываете название сети
        option encryption psk2
        option key      password #пароль от сети Wi-Fi

Перезагружаем службу network.

Код:
/etc/init.d/network restart


Подключаемся к вашей сети Wi-Fi и проверяем интернет. После всех манипуляций перезагружаем роутер.

Код:
reboot


Пользуемся интернетом с прошивкой OpenWRT.

Источник Aleksandr Tumanov  https://linuxtaxi.blogspot.com/2017/05/ … t-web.html

И еще одна

Итак, в наличии имеется роутер TP-Link с OpenWRT на борту. Задача — настроить L2TP-подключение к серверу Гаранта, чтобы заработал Интернет. Вроде бы ничего сложного, однако при попытке самостоятельной настройки через веб-интерфейс LuCi удалось настроить только интерфейс WAN для доступа к внутренней сети Гаранта. L2TP-соединение упорно не хотело подниматься. Перелопатив кучу информации, пришел к выводу, что настройку придется производить через консоль. Далее — обо всем по порядку.

Как выяснилось, в стандартной сборке OpenWRT отсутствуют модули для установления L2TP-соединения (самые распространенные — это OpenL2TP и xl2tpd). Так как роутер пока не имеет выхода в интернет, загрузить установочные пакеты (с зависимостями) придется вручную, используя WinSCP. Мною был выбран пакет xl2tpd.

1 Итак, для начала уточняем свою версию OpenWRT (можно через веб-интерфейс, вкладка Status — Overview — Firmware version), после чего переходим в соответствующую ветку пакетов OpenWRT на официальном сайте загрузок. К примеру, все нужные пакеты для моей версии OpenWRT (Attitude Adjustment 12.09-rc1) лежали здесь. Нам нужен, собственно, сам пакет xl2tpd и зависимости к нему: ip, resolveip, kmod-l2tp, kmod-pppol2tp, ppp-mod-pppol2tp. Скачиваем все вышеперечисленное в отдельную папку на ПК (должно получится 6 файлов с расширением *.ipk) и переименовываем файлы для удобства последующей установки, оставляя только название пакета и расширение (к примеру, «resolveip_2_ar71xx.ipk» стоит переименовать в «resolveip.ipk»), хотя это не обязательно.

2 Запускаем WinSCP и подключаемся к роутеру по протоколу SCP, используя сетевой адрес роутера (по умолчанию — 192.168.1.1), имя пользователя — root и назначенный вами пароль. Переходим в каталог /root и копируем туда наши 6 файлов; после завершения передачи закрываем WinSCP

3 Запускаем SSH-клиент Putty для доступа к CLI роутера. Протокол — SSH, порт 22, данные для соединения те же, что и для WinSCP. После установления соединения вы сразу оказываетесь в домашнем каталоге /root. Удостоверьтесь, что нужные для установки файлы присутствуют в каталоге, для этого наберите:

Код:
ls

Должен появиться список всех файлов, присутствующих в каталоге /root. Если все ок, приступайте к установке пакетов в следующем порядке:
ip
resolveip
kmod-l2tp
kmod-pppol2tp
ppp-mod-pppol2tp
xl2tpd

Для установки используйте команду:

Код:
opkg install

имя_пакета_полностью, например:

Код:
opkg install ip.ipk

Повторите процедуру установки для каждого пакета в указанной очередности. На каждом этапе должно быть сообщение об успешной установке.

4 После установки всех пакетов нужно вручную внести изменения в сетевые настройки. Открываем в текстовом редакторе файл /etc/config/network, набрав в консоли команду:

Код:
vi /etc/config/network

Найдите в этом файле секцию, посвященную интерфейсу «wan», откройте режим редактирования («i») и добавьте в эту секцию следующую строчку:
option reqopts ‘routes msstaticroutes’
Сохраните изменения, нажав один раз «Esc» после редактирования, а потом набрав «:wq» и нажав «Enter».

5 Измените вручную настройки фаервола, наберите в консоли:

Код:
vi /etc/hotplug.d/firewall/10-nat-reflection

В шестой и восьмой строчках этого файла замените слово «wan» на «vpn» (без кавычек, разумеется). Сохраните изменения, нажав один раз «Esc» после редактирования, а потом набрав «:wq» и нажав «Enter». После этого SSH-соединение можно закрывать.

6 Переходим в веб-интерфейс LuCi роутера, закладка «Network» («Сеть»). У вас там должны быть два интерфейса — wan и lan. Настроим для начала интерфейс wan, нажав «Edit». В первой вкладке — «General Setup» в качестве значения поля «Protocol» должно быть указано «DHCP-клиент». Далее перейдите на вкладку «Advanced Settings» и найдите поле «Override MAC address». Туда нужно вписать MAC-адрес, зарегистрированный у провайдера (в договоре Гаранта он указан вместе с логином и паролем), разделяя октеты двоеточием, после чего нажать «Save and Apply». Подождите, пока настройки применятся и вернитесь на страницу интерфейсов (вкладка «Network»), найдите интерфейс wan и нажмите «Connect». Должно произойти соединение с внутренней сетью провайдера, о чем будет свидетельствовать появившийся IPv4-адрес рядом с интерфейсом wan.

7 Создайте новый интерфейс (Network — «Add new interface…»), назовите его vpn, в качестве типа протокола укажите «L2TP», нажмите «Submit». Откроется окно настроек нового интерфейса. Укажите имя сервера (l2tp.internet.beeline.kz), а также ваши логин и пароль, указанные в договоре на предоставление услуг Интернет. Сохраните и перейдите в расширенные свойства созданного интерфейса (Advanced Settings), установите галочки на «Bring on boot» и «Use default gateway» и снимите галочку около «Use DNS servers advertised by peer», сохраните изменения. Перейдите на вкладку «Firewall» и добавьте интерфейс «vpn» в зону wan, сохраните изменения и перезагрузите роутер.

8 После перезагрузки, Зайдите на роутер через веб-интерфейс, проверьте вкладку «Network». На всех трех интерфейсах (lan, wan, vpn) должны быть назначены IPv4-адреса. Если это так, то вам повезло, и настройку L2TP-соединения (Быдлайн) на роутере TP-Link с OpenWRT можно считать практически законченной: осталось зайти на вкладку Network — DHCP and DNS — Server settings — General settings и снять галочки напротив пунктов Domain required и Rebind protection для корректной работы DNS.


Видео на эту же тему

2

Немалую часть прошлой ночи я потратил на то, чтобы заставить свежеприобретённый роутер раздавать билайновский интернет. Ни одной полностью рабочей инструкции мне найти не удалось, поэтому делюсь решением.
Билайн, как, вероятно, и некоторые другие российские провайдеры, использует подключение через L2TP. Причина вовсе не в том, что это такая замечательная технология, а в том, что использование CHAP-аутентификации облегчает идентификацию трафика пользователя в СОРМ. Нам же в результате приходится страдать.
В дефолтных сборках OpenWRT 15.05.1 отсутствует необходимый для подключения пакет xl2tp. Можно собрать кастомную прошивку, а можно накатить пакет на дефолтную (но для этого понадобится решить проблему курицы и яйца, ведь пакет закачивается из интернет-репозитория).
Настроить соединение через веб-интерфейс не получится, надо лезть в конфиг /etc/config/network. В нём надо исправить настройки интерфейса wan и добавить новый (у меня она называется beeline):

Код:
config interface 'wan'
    option proto 'dhcp'
    option ifname 'eth0.2'
    option reqopts 'routes msstaticroutes'

config interface 'beeline'
    option proto 'l2tp'
    option server 'tp.internet.beeline.ru'
    option username 'LOGIN'
    option password 'PASSWORD'
    option keepalive '20 5'

Что касается опции

   

Код:
option reqopts 'routes msstaticroutes'

честно признаюсь, не вникал, что она делает, и не уверен, что она нужна вообще. Просто в ходе экспериментов получил рабочую конфигурацию, где она была прописана. Скопировал из какого-то мануала.
Опция

     

Код:
option keepalive '20 5'

нужна, потому что без неё соединение будет рваться через 5–6 секунд после подключения, а потом снова устанавливаться.
В некоторых мануалах советуют прописывать разные метрики для интерфейсов — этого делать не нужно, так интернет доступен не будет! В других рекомендуют править какой-то системный скрипт, добавив в него задержку (sleep 5 или что-то вроде того) — этого делать тоже не надо, используйте опцию keepalive.
После этого остаётся только прописать интерфейс beeline в зону wan файрвола (в /etc/config/firewall руками или через веб-интерфейс).

3

OpenWrt с поддержкой L2TP из коробки

Ввиду того что у многих провайдеры используют L2TP, переход на Openwrt для новичка может вызвать вопросы так как в штатно компилированных сборках нет поддержки l2tp и много другого функционала который был в прошивке от производителя это протоколы L2TP, PPTP, DDNS, шейпер пока на основе wshaper, IPTV UDP Multicast +udpxy, плюс UPNP, поддержка usb удалена хотелось вырезать ipv6 но из-за luci-app-upnp удалить не вышло в этой сборке . Я попытался собрать прошивку со штатным функционалом - т.е все что было в последней прошивке от tp-link добавил в сборку openwrt на базе BARRIER BREAKER 14.07 которую и скомпилировал.

https://4pda.ru/forum/index.php?showtop … ry58588679

4

Код:
config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
	option reqopts 'routes msstaticroutes'

config interface 'beelinekz'
	option proto 'l2tp'
	option server 'l2tp.internet.beeline.kz'
	option username '099000ХХХХ'
	option password 'ПАРОЛЬ'
	option keepalive '20 5'

Вы здесь » [#DCBEELINEKZ] БИЛАЙН ХАБЫ КАЗАХСТАН » [OPENWRT/LEDE ] » Настройка L2TP-соединения ("Интернет Дома" Билайн Казахстан) в OpenWRT